ACME API Service Disruption

Incident Report for ACME Technologies

Postmortem

Issue Summary

AWS identified a degradation in the underlying hardware supporting one of our production load balancer instances. While AWS had scheduled automated maintenance to address this, the instance became unavailable earlier than the maintenance window and stopped handling traffic.

Impact

Traffic routing through this load balancer was disrupted while the instance was in an unexpected state.

Root Cause

The issue was caused by degradation of the AWS host hardware. Additionally, our monitoring did not immediately alert on the instance becoming unavailable due to a configuration gap in our monitoring coverage.

Resolution

The affected instance was restored once AWS completed the stop/start process required to move it off the degraded hardware, and normal traffic handling resumed.

Preventive Actions

We are updating our monitoring configuration to ensure all critical production components are actively monitored and alerted on, reducing time to detection for similar issues in the future.

Posted Feb 09, 2026 - 15:37 PST

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 08:27 PST

Monitoring

A fix has been implemented and we are closely motoring the platform to ensure stability.

Service should now be restored to ACME Checkouts and our API integrations.
Posted Feb 06, 2026 - 08:21 PST

Update

We are continuing to investigate this issue.
Posted Feb 06, 2026 - 07:59 PST

Update

We are continuing to investigate issues with Checkouts and various API endpoints.
Posted Feb 06, 2026 - 07:30 PST

Investigating

An issue has been identified with our e-commerce servers where a hard refresh of the internet browser is required. Our team is working to resolve the issue but for the interim, loading your browser without cached data browser will restore server.

To learn how to depending on your browser, visit: https://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache
Posted Feb 06, 2026 - 07:15 PST
This incident affected: ACME Platform (ACME eCommerce (B2C), ACME Backoffice (B2B), ACME API).