Disruption with ACME Fraud Shield - 3DS

Incident Report for ACME Technologies

Resolved

3DS service has been restored and will be reactivated for participating venues.
Posted Feb 11, 2026 - 14:09 PST

Monitoring

A service provider that powers our 3DS and Advanced Fraud Shield features is currently experiencing a platform outage, which is impacting our integration.

Our 3DS service has been temporarily disabled until this issue is resolved. Our team is closely monitoring and will re-enable this feature for applicable venues once the service has normalized.
Posted Feb 11, 2026 - 13:36 PST

Investigating

We are currently experiencing a critical error with our VISA 3DS solution. The matter has been escalated and we are working on a solution.

For the interim, 3DS has been disabled at applicable venues to unblock legitimate purchasers.
Posted Feb 11, 2026 - 12:57 PST
This incident affected: Payment Processing (VISA Cardinal 3D-Secure Service).