Worldpay Express Processing - Transaction Authorizations

Incident Report for ACME Technologies

Resolved

Incident Start: 11 Apr, 2025 09:37 UTC | Apr 11, 2025 05:37 EDT
Platform Affected: Transaction Processing - Transaction Authorizations
Issue: There was an incident affecting transaction authorizations on the Visa network.
Status: End of Impact
Impact: Some transactions may have experienced a timeout during processing.
Actions Taken to Restore Service: Worldpay technical resources have successfully fixed the issue and will continue to monitor the environment for stability.
Posted Apr 11, 2025 - 09:03 PDT
This incident affected: Payment Processing (Worldpay Express).