Platform Service Disruption - POS and Backoffice

Incident Report for ACME Technologies

Postmortem

09/12/2025 7am- 09/12/2025 9am PDT

Root Cause:
A resource-intensive operation was unexpectedly triggered, which led to API performance issues for a subset of users. For some venues, this resulted in intermittent API failures.

Mitigation:
We have updated operating procedures to prevent similar incidents in the future and have introduced additional checks and safeguards in the infrastructure layer to prevent resource-heavy operations from compromising system resources.

Posted Sep 15, 2025 - 14:56 PDT

Resolved

Our team has been monitoring and is no longer observing an impact to service.
Posted Sep 12, 2025 - 09:39 PDT

Investigating

ACME is experiencing a service disruption that is impacting the ACME Sales (POS) and Backoffice (B2B) application(s). ACME eCommerce is operational.

Our engineering team is investigating the issue and we will update this incident as soon as possible.
Posted Sep 12, 2025 - 07:55 PDT
This incident affected: ACME Platform (ACME Backoffice (B2B), ACME Sales POS application).