Platform Service Disruption
Incident Report for ACME Technologies
Resolved
According to Cloudflare, they have implemented a fix and are monitoring the results. Users trying to reach ACME from the affected servers and regions should be able to resume normal platform access and functionality.
Posted Jun 11, 2021 - 10:26 PDT
Identified
Due to a Cloudflare server disruption, anyone accessing ACME using the affected servers will experience degraded performance and may not be able to connect to ACME. Please see more specifics on Cloudflare's server status at https://www.cloudflarestatus.com/.

Our engineering team is investigating the issue and we will update this incident as soon as possible.
Posted Jun 11, 2021 - 09:27 PDT
This incident affected: ACME Platform (Access Control, ACME eCommerce (B2C), ACME Backoffice (B2B), ACME Sales POS application) and Cloudflare.